Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Form Submissions Not Populating the Sheet

Incident Report for Smartsheet Gov

Postmortem

On May 18th, 2025 at 8:30 PM PDT, an infrastructure change was made that prevented form submissions with contact data from populating on their corresponding sheet. Our Engineering team identified the issue at 10:40 AM PDT on 5/19/25. A fix was made to address this issue at 11:10 AM PDT and any impacted form submissions were processed and added to their sheets by 12:45 PM PDT.

Posted May 19, 2025 - 15:27 PDT

Resolved

This incident has been resolved.
Posted May 19, 2025 - 15:14 PDT

Monitoring

A fix has been implemented, so the issue will not reproduce and all impacted submissions have been restored to the sheets. We are monitoring to ensure continued stability of this feature.
Posted May 19, 2025 - 12:54 PDT

Identified

We have identified the issue and taken action to resolve. Form submissions moving forward will succeed. We are working on restoring form submissions which previously failed. We will continue to provide frequent updates as we work towards resolution.
Posted May 19, 2025 - 11:21 PDT

Investigating

We are currently investigating some customer reports of form submissions not reaching the sheet. We've determined that this only occurs when there is a contact field in the form. We will continue to provide frequent updates as we work towards resolution.
Posted May 19, 2025 - 11:03 PDT
This incident affected: Core Application (Forms).