Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Issues with Automated workflows
Incident Report for Smartsheet Gov
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 12:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2024 - 10:14 PDT
Investigating
We're investigating impact to our service regarding Automated Workflows. Users might experience delayed automations and issues with updating and creating new workflows.
Posted Sep 19, 2024 - 10:02 PDT