Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Investigating email notifications not delivered from Smartsheet Gov
Incident Report for Smartsheet Gov
Postmortem

Between September 24th, 6:02 PM PT and September 25th, 3:06 PM PT, customers experienced delays in receiving emails. The issue was identified and a fix was implemented. The problem has been fully resolved. We apologize for any inconvenience caused.

Posted Sep 26, 2024 - 07:43 PDT

Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 17:19 PDT
Monitoring
We have identified the issue and are taking actions to resolve.
Posted Sep 25, 2024 - 15:14 PDT
Investigating
We are currently investigating some customer reports of email not delivered from Smartsheet Gov. In-app notifications continue to function as expected. We will continue to provide frequent updates as we work towards resolution.
Posted Sep 25, 2024 - 14:15 PDT