This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 08, 2024 - 15:00 PDT
Scheduled
Due to the recent Certificate Revocation Incident caused by DigiCert, our existing Gov SAML certificates are non-compliant. To ensure our compliance promise to Gov customers, we will renew the Gov certificates today, Monday, August 5 at 3PM PST. We have communicated the situation and process to update certificates to our customers, but if you need assistance, please visit https://help.smartsheet.com/contact/smartsheetgov to engage our Support Team. Please continue to visit this page for live updates and system notices.
NOTE: Customers that do not use SAML Certificates in Smartsheet Gov will not be affected.
Posted Aug 08, 2024 - 09:16 PDT
This scheduled maintenance affected: Core Application (Smartsheet Login).