Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
App Slowness When Opening Sheets
Incident Report for Smartsheet Gov
Postmortem

On Monday April 22, 2021 at 6:14 AM PST, a small volume of customers reported slow loading times in Smartsheet Gov when opening sheets. At 8:13 AM PST the issue was impacting a large volume of customers and communication was posted that loading times were slower than normal. Upon investigation, the cause of the problem was identified as an issue with a front end feature check and a rollback was completed to improve degraded performance. At 10:50 AM PST the issue was resolved and normal load times were returned for Smartsheet Gov sheet users. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.

Posted Apr 26, 2024 - 12:10 PDT

Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 10:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2024 - 08:49 PDT
Identified
The issue has been identified and a fix is being implemented. We will provide an update in 60 minutes.
Posted Apr 22, 2024 - 07:59 PDT
Investigating
We are currently investigating some customer reports of slowness when opening sheets.
Posted Apr 22, 2024 - 07:19 PDT
This incident affected: Core Application.