Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Gov experiencing issues due to cloud provider outage
Incident Report for Smartsheet Gov
Resolved
This incident has been resolved.
Posted Nov 02, 2021 - 13:39 PDT
Update
Our Gov cloud host provider is currently experiencing an outage. Users may experience issues in Control Center and utilizing reports or other core features within Smartsheet Gov. For additional detail, please refer to: https://status.aws.amazon.com/govcloud
Posted Nov 02, 2021 - 11:14 PDT
Identified
Our Gov cloud host provider is currently experiencing an outage. For additional detail, please refer to:
https://status.aws.amazon.com/govcloud

We are currently working with them to remediate this issue.
Posted Nov 02, 2021 - 11:02 PDT
Investigating
We are currently investigating issues accessing Smartsheet Gov Control Center. We will provide an update in 30 minutes.
Posted Nov 02, 2021 - 10:48 PDT
This incident affected: Core Application and Control Center.